Share/Save

Minimum Browser Requirements

Web pages and Web-based applications hosted by the Santa Barbara Botanic Garden have a minimum set of requirements to ensure our website provides the best experience for our visitors.

Internet Explorer 7.0 8.0 9.0 10.0
Google Chrome † Latest stable
Mozilla Firefox † Latest stable
Safari Latest stable (desktop) iOS 4.† iOS 5.† iOS 6.†

† symbol (as in "iOS 6.†") indicates that the most-current non-beta version.
* symbol (see "iOS 4.†*"/"iOS 5.†*")"indicates a known shopping cart incompatibility. Specifically when using Safari 5.0.8 (Mac OS X 10.5 Leopard) and prior versions. Please use updated Safari (Mac OS X 10.6 Snow Leopard or later).

Supported Web Browsers

Microsoft Internet Explorer 7.0 or later

Google Chrome (latest stable)

Mozilla Firefox (latest stable)

Safari (latest stable)

* indicates a known SBBG.org shopping cart incompatibility (when using Safari 5.0.8 (Mac OS X 10.5 Leopard) and prior versions. Use updated Safari (Mac OS X 10.6 Snow Leopard or later)

Adobe Reader
We support Adobe Reader 8.0 or later. If you do not already have Adobe Reader, you can download a free copy directly from Adobe.

Mobile Devices
Our site is compatible with most web browsers and should display properly on a variety of devices.

Video
All of our video content is available as Flash Video. Adobe Flash Plug-in is required to view video on the Retirement System’s website.

Additional Information
Some web pages may require the web browser to support Javascript and to accept session–based cookies. By default, the major web browsers are configured to handle this requirement.

Shopping Cart Error?

If you are attempting to complete an online transaction and have experienced an error screen while using our online shopping cart, please contact the SBBG Registrar or call (805) 682-4726 ext.102 (Mon -Fri, 8am-5pm PST) for assistance.
We regret any inconvenience and will be happy to expedite your transaction by phone or email.

Web Browser Issues

We have received reports of our shopping cart displaying an error screen to users. If you experienced an error page as the result of an attempted online purchase, it may be browser version related.
Known OS/web browser incompatibilities: *Safari 5.0.8 (Mac OS X 10.5 Leopard) and prior versions - Use updated Safari (Mac OS X 10.6 Snow Leopard or later)

Web Site Support

We are eager to troubleshoot any technical problems to make your online shopping experience efficient and trouble-free. Your assistance is much appreciated: Report Web Site Issue